PHP Classes

How to use Latin Characters?

Recommend this page to a friend!

      Thesaurus tooltip  >  All threads  >  How to use Latin Characters?  >  (Un) Subscribe thread alerts  
Subject:How to use Latin Characters?
Summary:Can i use thesaurus with ?
Messages:9
Author:manuel maga
Date:2008-03-06 19:16:58
Update:2010-11-01 08:52:58
 

  1. How to use Latin Characters?   Reply   Report abuse  
Picture of manuel maga manuel maga - 2008-03-06 19:16:58
How to use the acents? ?
How to save in the CVS file?
How to display in the tooltip?
thanks.

  2. Re: How to use Latin Characters?   Reply   Report abuse  
Picture of Dmitry Sheiko Dmitry Sheiko - 2008-03-07 07:39:21 - In reply to message 1 from manuel maga
Just use UTF-8 charset and you will have no troubles. Did you mean CSV format? Use a text editor or use DB storing. Tooltips will be displayed by themselves

  3. Re: How to use Latin Characters?   Reply   Report abuse  
Picture of Alexey Belov Alexey Belov - 2008-03-15 19:46:41 - In reply to message 2 from Dmitry Sheiko
the same problem, I use UTF-8.

I've tried storing in database. The data from "description" I see well in phpmyadmin but in web page result in tool-tip it's only "??????" characters

Please help if possible

  4. Re: How to use Latin Characters?   Reply   Report abuse  
Picture of Alexey Belov Alexey Belov - 2009-03-18 07:05:55 - In reply to message 3 from Alexey Belov
if any latin characters as , etc. then tiptool shos "loading" and no descripton is displayed.

In database no clics are calculated for such problem words.

Any solution?

  5. Re: How to use Latin Characters?   Reply   Report abuse  
Picture of Dmitry Sheiko Dmitry Sheiko - 2009-03-19 09:51:06 - In reply to message 4 from Alexey Belov
Guys, actually there is no problem with it. Just make sure your DB in UTF8 or your CVS is saved in UTF8 charset. I used Thesaurus on different servers and for different languages like Russian, Korean and so on.

  6. Re: How to use Latin Characters?   Reply   Report abuse  
Picture of Alexey Belov Alexey Belov - 2009-03-20 05:46:11 - In reply to message 5 from Dmitry Sheiko
My hoster do use "UTF-8 Unicode (utf8)" for MySQL coding.

"term" field has "utf8_bin" coding

"description" can have "utf8_unicode_ci"

but anway if in term there is ,, or such symbol then only "loading" is dispayed in tiptool.

If I do use "utf8_unicode_ci" for "term" field then there is error not recognizing that "a" and "" terms are duplicated.

  7. Re: How to use Latin Characters?   Reply   Report abuse  
Picture of Alexey Belov Alexey Belov - 2009-07-14 11:31:02 - In reply to message 6 from Alexey Belov
can anyone provide any solution?

  8. Re: How to use Latin Characters?   Reply   Report abuse  
Picture of Vietravel247 Vietravel247 - 2010-10-03 16:42:16 - In reply to message 7 from Alexey Belov
add this line: mysql_query("SET NAMES 'utf8'", $db_connection);
in file db_controller.php

  9. Re: How to use Latin Characters?   Reply   Report abuse  
Picture of Alexey Belov Alexey Belov - 2010-11-01 08:52:58 - In reply to message 8 from Vietravel247
I got this line:
mysql_query("SET NAMES 'utf8'");
where I have problem for displaying only special latin characters.

But if I change to:
mysql_query("SET NAMES 'utf8'", $db_connection);

then no tooltip at all is displayed, even for normal english latin characters.

 
For more information send a message to info at phpclasses dot org.